PHP Розширення (Extensions) для WordPress

PHP Розширення (Extensions) для WordPress
0 голосів
1 Star2 Stars3 Stars4 Stars5 Stars (2 votes, average: 5,00 out of 5)
Loading...

Налаштування (оптимізація) сайту на Вордпресс починається, звісно з серверної частини. Перш, ніж встановлювати плагіни для оптимізації, слід використати всю потужність «зв’язки» PHP7.3-WordPress.

Ваш сервер оброблятиме клієнтські запити швидше, коли ви потурбуєтесь про потреби Вордпресс у спеціальних «розширеннях». Якщо ваш сайт на бюджетному shared-хостингу, то 70% вам надали доступ до cPanel.

Зазвичай, хостингер не активує останні версії PHP. Вам це слід зробити власноруч, якщо ви одразу цього не зробили.

Не забувайте про бекапи ))) Для цього скористайтесь «Майстром Резервного Копіювання» в розділі «Файли»

Для того, щоб переконатись в значимості наступних налаштувань, виконайте поточний замір швидкості і тп в GT-metrix.

Далі в «Панелі Керування» cPanel перейдіть в розділ «Програмне Забезпечення», далі у «Вибір версії PHP». Якщо поточна версія не PHP7.3, то обирайте і читаючи переклад з документації нижче відмічайте необхідне та виключайте зайве.

Вибір версії PHP

#Розширення PHP7 (Extensions) для сайтів на ВордПресс

WordPress core використовує розширення PHP. Якщо відсутнє бажане розширення, WordPress або повинен буде зробити більше роботи, щоб виконати завдання, з яким допомагає модуль, або, в гіршому випадку, видалить функціональність.

розширення PHP

Тому рекомендуються «розширення PHP», перелічені нижче:
  • curl – виконує операції з віддаленим запитом.
  • dom – використовується для перевірки вмісту Text Widget та для автоматичного налаштування IIS7+.
  • exif – дозволяє оброблювачу мультимедіа WordPress витягувати дані Exif із зображень.
  • fileinfo – використовується для виявлення MIME-типу завантаження файлів.
  • hash – використовується для хешування, включаючи паролі та оновлення пакетів.
  • json – використовується для зв’язку з іншими серверами.
  • mbstring – використовується для правильної обробки тексту в UTF8.
  • mysqli – підключається до MySQL для взаємодії з базами даних.
  • libsodium – підтверджує підписи та забезпечує надійні випадкові байти.
  • openssl – дозволяє підключення на основі SSL до інших хостів.
  • pcre – підвищує ефективність відповідності шаблонів при пошуку коду.
  • imagick – забезпечує кращу якість зображення для завантаження медіа. Дивіться, WP_Image_Editor незабаром! для деталей. Досконаліший розмір зображення (для менших зображень) та підтримка мініатюр PDF, коли також доступний сценарій Ghost.
  • xml – використовується для розбору XML, наприклад, від стороннього сайту.
  • zip – використовується для розпакування пакетів оновлень плагінів, тем та WordPress.

Для повноти нижче наведено список інших модулів PHP, які WordPress може використовувати в певних ситуаціях або якщо інші модулі недоступні. Це резервні копії або необов’язкові, і не обов’язково потрібні в оптимальному середовищі, але встановлення їх не зашкодить.

  • filter – використовується для надійної фільтрації вводу користувача.
  • gd – якщо Imagick не встановлений, бібліотека графічних файлів GD використовується як функціонально обмежена резервна копія для обробки зображень.
  • iconv – використовується для перетворення (конвертацій) між наборами символів.
  • mcrypt – генерує випадкові байти, коли libsodium та /dev/urandom недоступні.
  • simplexml – використовується для розбору XML-документів.
  • xmlreader – використовується для розбору XML-документів.
  • zlib – стиснення та декомпресія Gzip.

Наступні розширення використовуються для зміни файлів, таких як оновлення та встановлення плагінів/тем, коли файли не можливо записати на сервері.

  • ssh2
  • ftp
  • sockets (в разі, коли розширення ftp недоступне)

Пріоритетом транспортування є прямий IO файл, SSH2, розширення FTP PHP, FTP, реалізований за допомогою Sockets, і FTP, реалізований лише через PHP.

Розширення PHP7 (Extensions) для сайтів на ВордПресс

Особливості версій PHP для Вордпресс

PHP 7.3 або вище рекомендується, але WordPress працюватиме і на старих версіях. Зауважте, однак, що версії PHP нижче 7,1 досягли статусу «закінченого терміну служби» (EOL) і більше не отримують оновлень безпеки.

З цієї причини не рекомендуються версії PHP нижче 7,1.

Додаткові поради

В тому ж розділі перейдіть у підрозділ «Оптимізувати веб-сайт» та активуйте «Стиснути весь зміст». Тепер проведіть ще раз заміри швидкості вашого сайту. Оптимізація серверної частини «доступними вам інструментами» на цьому типі хостингу завершена. Якщо суттєвої різниці ви не відчули – міняйте хостинг

Використано матеріали (оригінальна документація) Handbook з сайту WordPress.org

Високих вам швидкостей!

Залишайтеся в Темі і слідкуйте за оновленнями!

Якщо вам недостатньо викладеного матеріалу 😉 , чи

Якщо вам потрібна допомога/порада 

заповніть Заявку нижче